PCSX2 Documentation/Code Formatting Guidelines: Difference between revisions

no edit summary
No edit summary
No edit summary
Line 13: Line 13:
Besides being obscenely ugly, this naming convention is totally impractical for modern programming via an IDE with autocomplete features. Coders using such tools want to do autocomplete by the subject of the variable's purpose, and are then automatically provisioned variable type information via tooltip, making the prefix neigh worthless. If I'm looking for the `MasterVolume` of a voice, I might think `VoiceVolumeMaster`, `MasterVolumeVoice`, or `VolumeVoiceMaster` and in fact I'll probably have no idea of it's a dword, word, int, or float value type. Any code using this naming convention will be changed to something more sensible.
Besides being obscenely ugly, this naming convention is totally impractical for modern programming via an IDE with autocomplete features. Coders using such tools want to do autocomplete by the subject of the variable's purpose, and are then automatically provisioned variable type information via tooltip, making the prefix neigh worthless. If I'm looking for the `MasterVolume` of a voice, I might think `VoiceVolumeMaster`, `MasterVolumeVoice`, or `VolumeVoiceMaster` and in fact I'll probably have no idea of it's a dword, word, int, or float value type. Any code using this naming convention will be changed to something more sensible.


'''Just don't do it.''' '''''_Ever._'''''
'''Just don't do it.''' '''''Ever.'''''


## Topic 2: Using PCSX2 and wxWidgets base types instead of C/C++ atomic types.
## Topic 2: Using PCSX2 and wxWidgets base types instead of C/C++ atomic types.
ninja
782

edits